Problem and Background
If a prod_id value from an Add to Cart event is not found in the list of all prod_id values from Product Page View pixel, will get flagged as an error. This metric gives the percentage of prod_ids that are seen in the Add to Cart pixel that are not visible in the Product Page View pixels within the last one day.
This check runs once a day across one full day of pixel logs.
Performance of a product on a merchant site is tracked using the product ID. If the ID is not consistently present through the conversion funnel, then add to cart and conversion stats for product ID are wrong across various dashboards and reports.
Examples :
“Top Product” query metrics for Add To Cart are wrong.
“Low ATC Rate Site Search Queries” report is not accurate since search query attribution is tied to ATCs of products.
“Funnel Analysis for Pages in the Collection” report has inaccurate ATC metrics.
When reconciling analytics data between systems, incorrect metrics affect the comparison.
Scenario
A user browses to product page ‘ABC’. A Product Page View pixel is fired with a prod_id field set to ‘ABC’. Next, they add this product to their shopping cart. An Add to Cart event is fired with its prod_id field set to ‘XYZ’.
When the data is analyzed, ‘XYZ’ is not found in the list of all the Product Page View pixel prod_id values and flag this as an issue.
Debugging Steps
- Reach out to Bloomreach Support for the list of prod_id values from Add to Cart events that are not found in Product Page View pixel prod_id values.
- Browse through the list of examples of this check and manually compare the product ids from Add to Cart with product ids from page view. It is possible that there is an extra suffix/prefix added to ids or those could be SKUs instead of product ids.
- Check for case sensitivity.
- How to reproduce the issue
a. Each example has a product id and canonical URL from the ATC pixel. The URL is usually the product page URL from which Add to Cart was done.
b. Go to that URL. This will generate Page View Pixels for that product.
c. Inspect the page to find out the product for which the product id in ATC pixel was received.
d. Perform Add to Cart for that product. This generated Add to Cart events.
e. Now compare product id from two pixels and correlate it with the common causes listed below.
Common Causes
- The Bloomreach pixel at you end is initiated before the variables relating to category id and category name are created in the clients dataLayer.
- Pixels work absolutely fine on desktop, but on mobile web - there are issues preventing the pixel from running correctly. This is less common on responsive site designs, but is common on sites that have a separate mobile web experience.
- The category/search page has an Add-to-Cart link which takes the user directly to the cart page (no intermediate page view occurs).
- Category/search page has a Quickview popup. The Quickview popup should fire a Quickview event pixel, but the pixel is not fired.
- Product page not firing the same product id as the Add to Cart pixel.
- Search redirect to a product page (e.g, product id search) generates a Search pixel instead of Product Page View pixel
- Product page has Add-to-Cart link for a complimentary product leading to no page view for a complimentary product. This occurs when the product page lists accessories as well e.g. oil lamp product page listing replacement wicks. There is an Add to Cart for the main product and for the accessory product as well. In this case, Page View pixel will have the product id of the main product. And when the main product is added to cart it has the product id of the main product. And when an accessory of a product is added to cart, the Add to Cart pixel has the product id of that accessory. So accessory products got added to cart without a page view. So unless somebody visits a product page where the accessory product is a main product, the accessory product id from a Page View pixel is not received. And in such a case, the lookup of Add to Cart id of accessory product fails.
Solution
- Reproduce the issue and request your technical team to fix your pixel implementation.
- If the scenario is such that the Category/Search page has an Add-to-Cart link that redirects the user to the cart page without any intermediate page view, reach out to the Bloomreach Support team with all the information.