Problem
The pixel report shows a drop in the product page view as depicted in the image below.
Possible Reasons
The following are the possible reasons for this issue to occur:
- Certain issues with the Pixel such as misclassification of ptype.
- _Productid missing in the Pixel report or not matching with the PIDs supplied in the feed.
Environment Details
This issue usually occurs in the Production environment if the Pixel implementation is not properly done, this can occur in both the Staging and Production environments.
Cause
According to the product documentation, any product, product bundle, product collection or SKU set needs to be classified as _brdata.ptype = “product”
Debugging Steps
- Check the Pixel end-to-end and ensure that the “ptype” is defined properly. To know more about Pixel check, refer to this document.
- Ensure that the _Prodid is getting captured properly and it shows the same PID in the feed.
- You can download the examples from the pixel monitor. Also, you should be able to validate the site using the pixel validator extension.
Solution
In certain cases, the issue is with Pixel implementation. It could also be due to backend pipeline failure. However, if it is because of pipeline failure, the data would be missing completely for all the reports. In that case, please reach out to Bloomreach Support.
To fix this issue:
If the issue is with “ptype”, contact your technical team to get the “ptype” corrected. It should be _brdata.ptype = “product”
If the issue is with missing or mismatched _Prodid in the report, check the implementation and fix the Pixel.